ArcGIS不同版本对Orcale、PostgreSQL和Dameng数据库版本的支持汇总

不同ArcGIS版本对数据库的要求不同,这篇文章专门整理的Orcale、PostgreSQL和Dameng三个数据库对不同版本的支持情况,仅供参考。如需详细内容,请查看官网。

GIS 工具
发布于 2020-03-31 阅读 1.1k

Orcale

官网地址:https://desktop.arcgis.com/zh-cn/system-requirements/latest/database-requirements-oracle.htm

Orcale ArcGIS/ArcGIS Pro
10.3 10.4 10.5 10.6/2.1、2.2 10.7/2.3、2.4❻ 10.8/2.5❻
19c 19.3.0.0 √❸ √❹❺ √❹
18c 18.4.0.0 √❷ √❹ √❹
18.3.0.0 √❷ √❹ √❹
12c R2 12.2.0.1 √❶ √❹ √❹
12c R1 12.1.0.2 √❹ √❹
12.1.0.1
11g R2 11.2.0.4
11.2.0.3
10g R2 10.2.0.3

❶ 您必须将 ArcGIS 10.5.1(Desktop、Engine、Server)Oracle 关键问题和 12.2.01 支持修补程序安装在所有 10.5.1 客户端计算机上,以使用 Oracle 12.2.01 和 ArcGIS。 ❷ 受 10.6.1 支持,前提是已安装 ArcGIS (Desktop, Engine, Server) 10.6.1 Support for Oracle 18c Patch。 ❸ 受 10.6.1 支持,前提是已安装 ArcGIS (Desktop, Engine, Server) Support for Oracle 19c Patch。 ❹ 指的是ArcGIS为标准版 2 (SE2)/企业版 (EE);默认都是标准版/标准独立版/企业版。 ❺ 从 ArcGIS Pro 2.4.2 开始支持 Oracle 19c。ArcGIS 10.7.x 支持 Oracle 19c,前提是已安装 ArcGIS (Desktop, Engine, Server) Support for Oracle 19c Patch。 ❻ 下列 Oracle 版本是 ArcGIS 支持的最低认证修补版本。这些版本的较新 Oracle 修补程序(包括修补程序集级别和过渡(一次性)修补程序)均受支持,但未经过认证。

PostgreSQL

官网地址:https://desktop.arcgis.com/zh-cn/system-requirements/latest/database-requirements-postgresql.htm

PostgreSQL PostGIS ArcGIS/ArcGIS Pro
10.3 10.4❻ 10.5❻ 10.6/2.1、2.2❼ 10.7/2.3、2.4❼ 10.8/2.5❼
11.5 2.5.1
11.2 √❹
10.10 2.4
10.7
10.3 √❶
9.6.15 2.3
9.6.12
9.6.8
9.5.12 2.2 √❷ √❺
9.5.3
9.4.8 √❸
9.4.5
9.3.13
9.3.5
9.3.5 2.1
9.2.14
9.2.9 2.0
9.1.14

❶ 支持开始于 ArcGIS 10.6.1 和 ArcGIS Pro 2.2。 ❷ ArcGIS 10.6.1 和 ArcGIS Pro 2.2 支持的最低版本是 PostgreSQL 9.5.12。 ❸ 支持将在 ArcGIS 10.6 和 ArcGIS Pro 2.1 之后结束。 ❹ 支持开始于 ArcGIS 10.7.1 和 ArcGIS Pro 2.4。 ❺ 支持将在 ArcGIS 10.7 和 ArcGIS Pro 2.3 之后结束。 ❻ ArcGIS 支持以下 PostgreSQL 和 PostGIS 版本。列出的特定版本为支持的最低次要版本,受支持的 PostgreSQL 和 PostGIS 各个主要版本均已经过认证。支持新次要版本,但是这些版本尚未经过认证。 ❼ ArcGIS 支持以下 PostgreSQL 和 PostGIS 版本。列出的特定版本为支持的最低次要版本,受支持的 PostgreSQL 各个主要版本均已经过认证。支持新次要版本,但是这些版本尚未经过认证。根据 PostgreSQL 定义,y 位置中的数字表示 PostgreSQL 9.x.y 版本中的次要版本。对于 PostgreSQL 10.x,x 位置中的数字表示次要版本。

Dameng

官网地址:https://desktop.arcgis.com/zh-cn/system-requirements/latest/database-requirements-dameng.htm

Dameng ArcGIS/ArcGIS Pro
10.4 10.5 10.6/2.1、2.2 10.7/2.3、2.4❸ 10.8/2.5❸
7.1.6.33
7.1.6
7.1.5.158 √❶
7.1.5 √❷

*Dameng 不支持地理数据库功能。 ❶ 支持 10.5.1 ❷ 支持 10.5 ❸ 下列 Dameng 版本是 ArcGIS 支持的最低版本。支持这些版本的修补程序或更新,但其尚未经过认证。

  • 本文类型: 原创
  • 本文出处:
  • 版权说明: 本站内容均采用©BY-NC-SA许可协议,版权归作者和本站所有!欢迎转载,但未经作者同意必须在文章页面注明原文出处,否则保留追究法律责任的权利。

坤尘记

I AM KUNCHEN!思绪如风,总会在某处停留;用轻灵的文字书写关于技术生活的奇思妙想。

浙ICP备2020045526号